From: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Date: Wed, 27 Apr 2022 17:58:33 +0000 (-0300)
Subject: ath79: use rtl8366s and rtl8366_smi as a module
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6e0f0eae5b48bddead035d9dd89b710c10c50337;p=openwrt%2Fstaging%2Fjogo.git

ath79: use rtl8366s and rtl8366_smi as a module

rtl8366s is used only by dlink_dir-825-b1 and the netgear_wndr family
(wndr3700, wndr3700-v2, wndr3800ch, wndr3800.dts, wndrmac-v1,
wndrmac-v2).

Not tested in real hardware.

With rtl8366rb, rtl8366s, rtl8367 as modules, rtl8366_smi can also be a
loadable module. This change was tested with tl-wr2543-v1.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
---

diff --git a/target/linux/ath79/generic/config-default b/target/linux/ath79/generic/config-default
index 3b986f6620..dd59a35490 100644
--- a/target/linux/ath79/generic/config-default
+++ b/target/linux/ath79/generic/config-default
@@ -19,7 +19,5 @@ CONFIG_PHY_AR7100_USB=y
 CONFIG_PHY_AR7200_USB=y
 CONFIG_REALTEK_PHY=y
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_RTL8366S_PHY=y
-CONFIG_RTL8366_SMI=y
 CONFIG_VITESSE_PHY=y
 CONFIG_WATCHDOG_CORE=y
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4cc89a4b97..7442a0f68c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -998,7 +998,7 @@ define Device/dlink_dir-825-b1
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
 	check-size | append-metadata
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
-	kmod-leds-reset kmod-owl-loader
+	kmod-leds-reset kmod-owl-loader kmod-switch-rtl8366s
   SUPPORTED_DEVICES += dir-825-b1
 endef
 TARGET_DEVICES += dlink_dir-825-b1
@@ -1709,7 +1709,7 @@ define Device/netgear_wndr3x00
   $(Device/netgear_generic)
   SOC := ar7161
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
-	kmod-leds-reset kmod-owl-loader
+	kmod-leds-reset kmod-owl-loader kmod-switch-rtl8366s
 endef
 
 define Device/netgear_wndr3700