From: Luka Perkov <luka@openwrt.org>
Date: Mon, 15 Jul 2013 23:18:37 +0000 (+0000)
Subject: imx6: use $PATH to locate dtc binary
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6ef9d30da76819531486bcc2da6488a54c260a34;p=openwrt%2Fstaging%2Fansuel.git

imx6: use $PATH to locate dtc binary

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 37362
---

diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 975328f003..04a446d98f 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -16,7 +16,7 @@ define mkfit
 		-v 'OpenWrt Linux-$(LINUX_VERSION)' \
 		-d $(LINUX_DIR)/arch/arm/boot/dts/$(1).dtb -k $(LINUX_DIR)/arch/arm/boot/zImage \
 		-o $(KDIR)/$(1)-uImage.its
-	mkimage -B $(LINUX_DIR)/scripts/dtc/dtc -f $(KDIR)/$(1)-uImage.its $(BIN_DIR)/openwrt-$(1)-uImage.itb
+	PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/$(1)-uImage.its $(BIN_DIR)/openwrt-$(1)-uImage.itb
 endef
 
 # emit FIT images, DTB's and generic zImage