From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 18 Jul 2013 17:26:32 +0000 (+0000)
Subject: kernel: usb-serial-keyspan needs to include ezusb.ko
X-Git-Tag: reboot~9819
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=6fc24f776800332c94fcaf7cd2f2355e187f0b6b;p=openwrt%2Fstaging%2Fpepe2k.git

kernel: usb-serial-keyspan needs to include ezusb.ko

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37413
---

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 8df5c8a004..85f32de5bc 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -530,7 +530,9 @@ define KernelPackage/usb-serial-keyspan
 	CONFIG_USB_SERIAL_KEYSPAN_MPR \
 	CONFIG_USB_SERIAL_KEYSPAN_USA49W \
 	CONFIG_USB_SERIAL_KEYSPAN_USA49WLC
-  FILES:=$(LINUX_DIR)/drivers/usb/serial/keyspan.ko
+  FILES:= \
+	$(LINUX_DIR)/drivers/usb/serial/keyspan.ko \
+	$(wildcard $(LINUX_DIR)/drivers/usb/misc/ezusb.ko)
   AUTOLOAD:=$(call AutoLoad,65,keyspan)
   $(call AddDepends/usb-serial)
 endef