From: Imre Kaloz <kaloz@openwrt.org>
Date: Mon, 19 Mar 2012 11:27:34 +0000 (+0000)
Subject: [ppc44x]: upgrade to 3.2, disable ppp by default until we figure out why ppp_generic... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=71166cd94cb69eaba15e594d67636b860f66f88b;p=openwrt%2Fsvn-archive%2Farchive.git

[ppc44x]: upgrade to 3.2, disable ppp by default until we figure out why ppp_generic breaks bootup

SVN-Revision: 31020
---

diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index ed5718764a..629eab0361 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,10 +13,12 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.18
+LINUX_VERSION:=3.2.11
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+
 define Target/Description
 	Build firmware images for AMCC/IBM PPC44x based boards.
 endef
diff --git a/target/linux/ppc44x/config-default b/target/linux/ppc44x/config-default
index bec21b5825..ffbbc0a8e4 100644
--- a/target/linux/ppc44x/config-default
+++ b/target/linux/ppc44x/config-default
@@ -77,6 +77,17 @@ CONFIG_HW_RANDOM=y
 # CONFIG_HZ_100 is not set
 CONFIG_HZ=250
 CONFIG_HZ_250=y
+# CONFIG_IBM_EMAC_DEBUG is not set
+CONFIG_IBM_EMAC_EMAC4=y
+CONFIG_IBM_EMAC_POLL_WEIGHT=32
+CONFIG_IBM_EMAC_RGMII=y
+CONFIG_IBM_EMAC_RXB=128
+CONFIG_IBM_EMAC_RX_COPY_THRESHOLD=256
+CONFIG_IBM_EMAC_RX_SKB_HEADROOM=0
+CONFIG_IBM_EMAC_TAH=y
+CONFIG_IBM_EMAC_TXB=128
+CONFIG_IBM_EMAC=y
+CONFIG_IBM_EMAC_ZMII=y
 # CONFIG_IBM_NEW_EMAC_DEBUG is not set
 CONFIG_IBM_NEW_EMAC_EMAC4=y
 CONFIG_IBM_NEW_EMAC_POLL_WEIGHT=32