From: John Crispin <john@openwrt.org>
Date: Sat, 12 Apr 2014 21:21:44 +0000 (+0000)
Subject: Don't try to generate whr-g300n image if it's going to be more than 4M
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=72803e0e27ec149784ff22ee528a7c11c6eefed1;p=openwrt%2Fstaging%2Fsvanheule.git

Don't try to generate whr-g300n image if it's going to be more than 4M

Signed-off-by: Roman Yeryomin <roman@advem.lv>

SVN-Revision: 40489
---

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c6a42ad8e7..63f7425a9e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -456,13 +456,15 @@ define BuildFirmware/WHRG300N/squashfs
 	$(call BuildFirmware/Default4M/$(1),$(1),whr-g300n,WHR-G300N)
 	# the following line has a bad argument 3 ... the old Makefile was already broken	
 	$(call BuildFirmware/Buffalo,$(1),whr-g300n,whr-g300n)
-	( \
-		echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
-			dd bs=512 count=1 conv=sync; \
-		dd if=$(call sysupname,$(1),whr-g300n); \
-	) > $(KDIR)/whr-g300n-tftp.tmp
-	buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
-		-o $(call imgname,$(1),whr-g300n)-tftp.bin
+	if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+		( \
+			echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
+				dd bs=512 count=1 conv=sync; \
+			dd if=$(call sysupname,$(1),whr-g300n); \
+		) > $(KDIR)/whr-g300n-tftp.tmp && \
+		buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
+			-o $(call imgname,$(1),whr-g300n)-tftp.bin; \
+	fi
 endef
 BuildFirmware/WHRG300N/initramfs=$(call BuildFirmware/OF/initramfs,$(1),whr-g300n,WHR-G300N)
 Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))