From: Pawel Dembicki <paweldembicki@gmail.com>
Date: Thu, 30 Apr 2020 10:18:24 +0000 (+0200)
Subject: kirkwood: move sata features to modules
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=73c3ba23a4cf973ca03e0e1ec0d4afa306fb7659;p=openwrt%2Fstaging%2Fldir.git

kirkwood: move sata features to modules

All devices are using nand images. Built-in SATA modules are not needed
anymore.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
[only move CONFIG_SATA_MV]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Tested-by: Pawel Dembicki <paweldembicki@gmail.com> [pogo v4]
---

diff --git a/target/linux/generic/config-4.14 b/target/linux/generic/config-4.14
index 99e4075654..bcf47f10d1 100644
--- a/target/linux/generic/config-4.14
+++ b/target/linux/generic/config-4.14
@@ -350,6 +350,7 @@ CONFIG_ATAGS_PROC=y
 # CONFIG_ATA_ACPI is not set
 CONFIG_ATA_BMDMA=y
 # CONFIG_ATA_GENERIC is not set
+# CONFIG_ATA_LEDS is not set
 # CONFIG_ATA_NONSTANDARD is not set
 # CONFIG_ATA_OVER_ETH is not set
 # CONFIG_ATA_PIIX is not set
diff --git a/target/linux/generic/config-4.19 b/target/linux/generic/config-4.19
index 7e530f347f..aa0b0e0b20 100644
--- a/target/linux/generic/config-4.19
+++ b/target/linux/generic/config-4.19
@@ -359,6 +359,7 @@ CONFIG_ATAGS_PROC=y
 # CONFIG_ATA_ACPI is not set
 CONFIG_ATA_BMDMA=y
 # CONFIG_ATA_GENERIC is not set
+# CONFIG_ATA_LEDS is not set
 # CONFIG_ATA_NONSTANDARD is not set
 # CONFIG_ATA_OVER_ETH is not set
 # CONFIG_ATA_PIIX is not set
diff --git a/target/linux/generic/config-5.4 b/target/linux/generic/config-5.4
index ea4e9a5d3f..aca72b8fae 100644
--- a/target/linux/generic/config-5.4
+++ b/target/linux/generic/config-5.4
@@ -399,6 +399,7 @@ CONFIG_ATAGS_PROC=y
 # CONFIG_ATA_ACPI is not set
 CONFIG_ATA_BMDMA=y
 # CONFIG_ATA_GENERIC is not set
+# CONFIG_ATA_LEDS is not set
 # CONFIG_ATA_NONSTANDARD is not set
 # CONFIG_ATA_OVER_ETH is not set
 # CONFIG_ATA_PIIX is not set
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index c14ca3778f..4be83a5139 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -305,7 +305,6 @@ CONFIG_REGULATOR_FIXED_VOLTAGE=y
 CONFIG_RTC_CLASS=y
 CONFIG_RTC_DRV_MV=y
 CONFIG_RTC_I2C_AND_SPI=y
-CONFIG_SATA_MV=y
 CONFIG_SATA_PMP=y
 CONFIG_SCSI=y
 CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 552ee44ee4..76dfc4ea09 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -50,7 +50,7 @@ define Device/cloudengines_pogoplugv4
   DEVICE_VENDOR := Cloud Engines
   DEVICE_MODEL := Pogoplug V4
   DEVICE_DTS := kirkwood-pogoplug-series-4
-  DEVICE_PACKAGES := kmod-usb3
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
 endef
 TARGET_DEVICES += cloudengines_pogoplugv4
 
@@ -65,7 +65,8 @@ define Device/iom_ix2-200
   DEVICE_VENDOR := Iomega
   DEVICE_MODEL := StorCenter ix2-200
   DEVICE_DTS := kirkwood-iomega_ix2_200
-  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-hwmon-lm63
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
+	kmod-hwmon-lm63
   PAGESIZE := 512
   SUBPAGESIZE := 256
   BLOCKSIZE := 16k
@@ -110,6 +111,7 @@ define Device/raidsonic_ib-nas62x0
   DEVICE_VENDOR := RaidSonic
   DEVICE_MODEL := ICY BOX IB-NAS62x0
   BOARD_NAME := ib62x0
+  DEVICE_PACKAGES := kmod-ata-marvell-sata
 endef
 TARGET_DEVICES += raidsonic_ib-nas62x0
 
@@ -124,6 +126,7 @@ define Device/seagate_goflexnet
   DEVICE_VENDOR := Seagate
   DEVICE_MODEL := GoFlexNet
   BOARD_NAME := goflexnet
+  DEVICE_PACKAGES := kmod-ata-marvell-sata
 endef
 TARGET_DEVICES += seagate_goflexnet
 
@@ -131,13 +134,15 @@ define Device/seagate_goflexhome
   DEVICE_VENDOR := Seagate
   DEVICE_MODEL := GoFlexHome
   BOARD_NAME := goflexhome
+  DEVICE_PACKAGES := kmod-ata-marvell-sata
 endef
 TARGET_DEVICES += seagate_goflexhome
 
 define Device/zyxel_nsa310b
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA310b
-  DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-r8169 \
+	kmod-gpio-button-hotplug kmod-hwmon-lm85
   BOARD_NAME := nsa310b
 endef
 TARGET_DEVICES += zyxel_nsa310b
@@ -146,7 +151,8 @@ define Device/zyxel_nsa325
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA325
   DEVICE_VARIANT := v1/v2
-  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
+	kmod-rtc-pcf8563 kmod-usb3
   BOARD_NAME := nsa325
 endef
 TARGET_DEVICES += zyxel_nsa325