From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 27 Sep 2006 18:57:25 +0000 (+0000)
Subject: use -f option when calling trx (osx build works now)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=74b8e091944d9142a93e2e21cfc76b0dba916ed1;p=openwrt%2Fstaging%2Fansuel.git

use -f option when calling trx (osx build works now)

SVN-Revision: 4871
---

diff --git a/openwrt/target/image/brcm/Makefile b/openwrt/target/image/brcm/Makefile
index a4d505865f..2dc599daea 100644
--- a/openwrt/target/image/brcm/Makefile
+++ b/openwrt/target/image/brcm/Makefile
@@ -48,7 +48,7 @@ define trxalign/squashfs
 endef
 
 define Image/Build
-	$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx $(KDIR)/loader.gz $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) $(KDIR)/root.$(1)
+	$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
 ifneq ($(1),jffs2-128k)
 	$(call Image/Build/CyberTAN,$(1),wrt54g3g,W54F,1.99.5,$(patsubst jffs2-%,jffs2,$(1)))
 	$(call Image/Build/CyberTAN,$(1),wrt54g,W54G,4.40.1,$(patsubst jffs2-%,jffs2,$(1)))