From: Ben Whitten <ben.whitten@gmail.com>
Date: Sun, 19 Jun 2016 22:49:16 +0000 (+0100)
Subject: linux-firmware: add ath6k firmware to package
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=76662637fadba33d698c60f754e67645edf3ce50;p=openwrt%2Fstaging%2Fynezz.git

linux-firmware: add ath6k firmware to package

Systems which include the ath6k chipset need to have the firmware included
in the image.

Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
---

diff --git a/package/firmware/linux-firmware/qca.mk b/package/firmware/linux-firmware/qca.mk
index 7ad27ef388..0a809d1a21 100644
--- a/package/firmware/linux-firmware/qca.mk
+++ b/package/firmware/linux-firmware/qca.mk
@@ -7,6 +7,16 @@ define Package/ar3k-firmware/install
 endef
 $(eval $(call BuildPackage,ar3k-firmware))
 
+
+Package/ath6k-firmware = $(call Package/firmware-default,AR600X firmware)
+define Package/ath6k-firmware/install
+	$(INSTALL_DIR) $(1)/lib/firmware/ath6k
+	$(CP) \
+		$(PKG_BUILD_DIR)/ath6k/* \
+		$(1)/lib/firmware/ath6k
+endef
+$(eval $(call BuildPackage,ath6k-firmware))
+
 Package/ath9k-htc-firmware = $(call Package/firmware-default,AR9271/AR7010 firmware)
 define Package/ath9k-htc-firmware/install
 	$(INSTALL_DIR) $(1)/lib/firmware/ath9k_htc