From: Florian Fainelli <florian@openwrt.org>
Date: Wed, 19 Sep 2012 15:13:44 +0000 (+0000)
Subject: base-files: release an attached loop device on umounting
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=78f4cf3d70f7646e182fc98ba65b4d9ede0240d3;p=openwrt%2Fstaging%2Fdedeckeh.git

base-files: release an attached loop device on umounting

Signed-off-by: Michael Heimpold <mhei@heimpold.de>

SVN-Revision: 33477
---

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 13927528c0..1d56e9fc78 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=116
+PKG_RELEASE:=117
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/umount b/package/base-files/files/etc/init.d/umount
index a4e477e2e9..5a750b93c6 100755
--- a/package/base-files/files/etc/init.d/umount
+++ b/package/base-files/files/etc/init.d/umount
@@ -4,5 +4,5 @@
 STOP=99
 stop() {
 	sync
-	umount -a -r
+	umount -a -d -r
 }