From: Jonas Gorski <jogo@openwrt.org>
Date: Fri, 4 Sep 2015 14:44:48 +0000 (+0000)
Subject: ipq806x: wrap legacy image in uImage
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7a962fb55aa836c9bc6f2bdaa75e81ab8c41279c;p=openwrt%2Fstaging%2Fnbd.git

ipq806x: wrap legacy image in uImage

Wrap the zImage in a uImage header so we can easily boot it from legacy
u-boots.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 46787
---

diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b64d629be3..2369762ad8 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -38,8 +38,8 @@ endef
 DEVICE_VARS += DEVICE_DTS
 
 define Device/LegacyImage
-	KERNEL_SUFFIX := -zImage
-	KERNEL = kernel-bin | append-dtb
+	KERNEL_SUFFIX := -uImage
+	KERNEL = kernel-bin | append-dtb | uImage none
 	KERNEL_NAME := zImage
 	KERNEL_INSTALL := 1
 endef