From: Andy Strohman <andrew@andrewstrohman.com>
Date: Sun, 18 Dec 2016 19:06:06 +0000 (-0800)
Subject: ath10k-ct: Enable DFS when "Enable DFS support" is set for kmod-ath
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7acb7dc3db823687b0c05a0b0ee31e05267ff551;p=openwrt%2Fstaging%2Fldir.git

ath10k-ct: Enable DFS when "Enable DFS support" is set for kmod-ath

This allows users of this package to configure DFS channels.
It mimics the behaviour of the ath10k module included in
package mac80211

Signed-off-by: Andy Strohman <andrew@andrewstrohman.com>
---

diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index c5e5045124..97f284efbf 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -61,6 +61,10 @@ ifdef CONFIG_PACKAGE_ATH_DEBUG
   NOSTDINC_FLAGS += -DCONFIG_ATH10K_DEBUG
 endif
 
+ifdef CONFIG_PACKAGE_ATH_DFS
+  NOSTDINC_FLAGS += -DCONFIG_ATH10K_DFS_CERTIFIED
+endif
+
 define Build/Configure
 	cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
 endef