From: Felix Fietkau <nbd@openwrt.org>
Date: Fri, 8 May 2015 14:02:50 +0000 (+0000)
Subject: ar71xx: allow mktplinkfw calls from the new image code to fail (because of oversized... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7b01a650f8ad8d22c360d359432ffe5365bbee4f;p=openwrt%2Fstaging%2Fldir.git

ar71xx: allow mktplinkfw calls from the new image code to fail (because of oversized images)

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 45646
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 00d61ba113..d6e6285c74 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -51,15 +51,14 @@ endef
 # -s strip padding from end of the image
 # -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
 define Build/mktplinkfw
-	$(STAGING_DIR_HOST)/bin/mktplinkfw \
+	-$(STAGING_DIR_HOST)/bin/mktplinkfw \
 		-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
 		-k $(word 1,$^) \
 		-r $@ \
 		-o $@.new \
 		-j -X 0x40000 \
 		-a $(call rootfs_align,$(FILESYSTEM)) \
-		$(if $(findstring sysupgrade,$1),-s)
-	@mv $@.new $@
+		$(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
 endef
 
 # -c combined image