From: Mike Baker <mbm@openwrt.org>
Date: Mon, 15 May 2006 20:30:26 +0000 (+0000)
Subject: avoid running timestamp.pl for dumpinfo -- drastically speeds up the .pkginfo process
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7bd78892a575a266fc1cccfdfe2b13df1f26fd2c;p=openwrt%2Fstaging%2Fthess.git

avoid running timestamp.pl for dumpinfo -- drastically speeds up the .pkginfo process

SVN-Revision: 3780
---

diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index a0cdd1e31e..e8417c3a5f 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -5,12 +5,14 @@ else
 endif
 
 define Build/DefaultTargets
-  ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
-    $(PKG_BUILD_DIR)/.prepared: package-clean
-  endif
+  ifeq ($(DUMP),)
+    ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
+      $(PKG_BUILD_DIR)/.prepared: package-clean
+    endif
 
-  ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-    $(PKG_BUILD_DIR)/.built: package-rebuild
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
+      $(PKG_BUILD_DIR)/.built: package-rebuild
+    endif
   endif
 
   $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
@@ -191,6 +193,7 @@ define Build/Configure/Default
 		--infodir=/usr/info \
 		$(DISABLE_NLS) \
 		$(1); \
+		true; \
 	)
 endef
 
@@ -205,11 +208,12 @@ define Build/Compile/Default
 		PREFIX="$$(IDIR_$(1))" \
 		EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
 		ARCH="$(ARCH)" \
-		DESTDIR="$$(IDIR_$(1))"
+		DESTDIR="$$(IDIR_$(1))" \
+		$(1);
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default)
+  $(call Build/Compile/Default,)
 endef
 
 define Build/Clean
@@ -217,7 +221,7 @@ define Build/Clean
 endef
 
 ifneq ($(DUMP),)
-  dumpinfo:
+  dumpinfo: FORCE
 	$(DUMPINFO)
 else