From: Hauke Mehrtens <hauke.mehrtens@intel.com>
Date: Tue, 14 Mar 2017 17:55:03 +0000 (+0100)
Subject: include: Add nomips16 CPU_SUBTYPE
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7c7ea090041dc2a5e51b36d0bc3115a8830525bf;p=openwrt%2Fstaging%2Fldir.git

include: Add nomips16 CPU_SUBTYPE

This can be used to indicate that a target does not support the optional mips16
extension even when it is a mips32r2 or later CPU.

This will generate a separate toolchain and a separate package folder,
e.g. mips_24kc_nomips16

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
---

diff --git a/include/target.mk b/include/target.mk
index 5490d4882f..61489cabe7 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -258,7 +258,9 @@ ifeq ($(DUMP),1)
       FEATURES += virtio
     endif
     ifneq ($(CONFIG_CPU_MIPS32_R2),)
-      FEATURES += mips16
+      ifneq ($(CPU_SUBTYPE),nomips16)
+        FEATURES += mips16
+      endif
     endif
     FEATURES += $(foreach v,6 7,$(if $(CONFIG_CPU_V$(v)),arm_v$(v)))