From: John Crispin <john@openwrt.org>
Date: Sun, 14 Jul 2013 18:16:42 +0000 (+0000)
Subject: swconfig: fix dependency bug introduced by [37304]
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7d7c2ff5f9fd6f195119961fd696cd4193ebf3b5;p=openwrt%2Fstaging%2Fansuel.git

swconfig: fix dependency bug introduced by [37304]

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 37316
---

diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index 417845dcb3..65593b20d6 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/kernel.mk
 define Package/swconfig
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=!@LINUX_3_10:TARGET_brcm47xx +libuci +libnl-tiny
+  DEPENDS:=@(!TARGET_brcm47xx||LINUX_3_10) +libuci +libnl-tiny
   TITLE:=Switch configuration utility
 endef