From: Philip Prindeville <philipp@redfish-solutions.com>
Date: Tue, 21 Apr 2020 08:29:51 +0000 (-0600)
Subject: kmod-nft-reject: Fix for "nft_reject_ipv4.ko missing" warning
X-Git-Tag: v21.02.0-rc1~1245
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b;p=openwrt%2Fstaging%2Fpepe2k.git

kmod-nft-reject: Fix for "nft_reject_ipv4.ko missing" warning

Seeing the following:

    ERROR: module '/home/philipp/lede/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.33/net/ipv4/netfilter/nft_reject_ipv4.ko' is missing.
    modules/netfilter.mk:1068: recipe for target '/home/philipp/lede/bin/targets/x86/64/packages/kmod-nft-core_5.4.33-1_x86_64.ipk' failed
    make[3]: *** [/home/philipp/lede/bin/targets/x86/64/packages/kmod-nft-core_5.4.33-1_x86_64.ipk] Error 1

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
---

diff --git a/include/netfilter.mk b/include/netfilter.mk
index 2c71c07056..b00cdd81c6 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -344,7 +344,7 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_NUMGEN, $(P_XT)nft_numg
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_OBJREF, $(P_XT)nft_objref),))
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_QUOTA, $(P_XT)nft_quota),))
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REDIR, $(P_XT)nft_redir),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REJECT, $(P_XT)nft_reject $(P_V4)nft_reject_ipv4 $(P_V6)nft_reject_ipv6),))
+$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REJECT CONFIG_NFT_REJECT_IPV4 CONFIG_NFT_REJECT_IPV6, $(P_XT)nft_reject $(P_V4)nft_reject_ipv4 $(P_V6)nft_reject_ipv6),))
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REJECT_INET, $(P_XT)nft_reject_inet),))
 
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_BRIDGE,CONFIG_NFT_BRIDGE_META, $(P_EBT)nft_meta_bridge),))
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 83bb59be83..9f9798179f 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1058,6 +1058,9 @@ define KernelPackage/nft-core
   KCONFIG:= \
 	CONFIG_NFT_COMPAT=n \
 	CONFIG_NFT_QUEUE=n \
+	CONFIG_NFT_REJECT_INET \
+	CONFIG_NFT_REJECT_IPV4 \
+	CONFIG_NFT_REJECT_IPV6 \
 	$(KCONFIG_NFT_CORE)
 endef