From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 22 Feb 2007 04:03:35 +0000 (+0000)
Subject: ignore profiles with custom kernel configs in the image builder itself
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=804bfa954d66373e71b8224f4df2b5f09481f797;p=openwrt%2Fstaging%2Fwigyori.git

ignore profiles with custom kernel configs in the image builder itself

SVN-Revision: 6342
---

diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 4a05628a54..063524a67b 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -149,9 +149,10 @@ sub gen_target_mk() {
   define Profile/$conf\_$profile->{id}
     ID:=$profile->{id}
     NAME:=$profile->{name}
-    PACKAGES:=".join(" ", @{$profile->{packages}})."
-  endef";
-  $profiles_eval .= "
+    PACKAGES:=".join(" ", @{$profile->{packages}})."\n";
+			$profile->{kconfig} and $profiles_def .= "    KCONFIG:=1\n";
+			$profiles_def .= "  endef";
+			$profiles_eval .= "
 \$(eval \$(call AddProfile,$conf\_$profile->{id}))"
 		}
 		print "
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index b36e2f2e31..8b386a33c6 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -34,6 +34,7 @@ IPKG:= \
 define Profile/Default
   ID:=
   NAME:=
+  KCONFIG:=
   PACKAGES:=
 endef
 
@@ -46,8 +47,10 @@ define AddProfile
     endif
 	$(ID)_NAME:=$(NAME)
 	$(ID)_PACKAGES:=$(PACKAGES)
-    PROFILE_LIST += \
+    ifneq ($(KCONFIG),)
+      PROFILE_LIST += \
   		echo '$(ID):'; [ -z '$(NAME)' ] || echo '	$(NAME)'; echo '	Packages: $(PACKAGES)';
+    endif
   endif
 endef