From: Vasilis Tsiligiannis <acinonyx@openwrt.gr>
Date: Tue, 1 Feb 2011 16:37:53 +0000 (+0000)
Subject: hotplug2: Use stricter matching for rule regular expressions
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=824331a5943c0acfbb7b1fc95116c77092660f1e;p=openwrt%2Fstaging%2Flinusw.git

hotplug2: Use stricter matching for rule regular expressions

SVN-Revision: 25282
---

diff --git a/package/base-files/files/etc/hotplug2-common.rules b/package/base-files/files/etc/hotplug2-common.rules
index 0487ce9dfb..bd30e55632 100644
--- a/package/base-files/files/etc/hotplug2-common.rules
+++ b/package/base-files/files/etc/hotplug2-common.rules
@@ -4,31 +4,31 @@
 # 	exec logger -s -t hotplug -p daemon.info "name=%DEVICENAME%, path=%DEVPATH%"
 # }
 
-DEVICENAME ~~ (null|full|ptmx|tty|zero|gpio|hvc) {
+DEVICENAME ~~ (^null$|^full$|^ptmx$|^tty|^zero$|^gpio|^hvc) {
 	makedev /dev/%DEVICENAME% 0666
 	next-event
 }
 
-DEVICENAME ~~ (tun|tap[0-9]) {
+DEVICENAME ~~ (^tun|^tap[0-9]$) {
 	makedev /dev/net/%DEVICENAME% 0644
 }
 
-DEVICENAME ~~ (ppp) {
+DEVICENAME ~~ ^ppp {
 	makedev /dev/%DEVICENAME% 0600
 	next-event
 }
 
-DEVICENAME ~~ (controlC[0-9]|pcmC0D0*|timer) {
+DEVICENAME ~~ (^controlC[0-9]$|^pcmC0D0|^timer$) {
 	makedev /dev/snd/%DEVICENAME% 0644
 	next-event
 }
 
-DEVICENAME ~~ (lp[0-9]) {
+DEVICENAME ~~ ^lp[0-9]$ {
 	makedev /dev/%DEVICENAME% 0644
 	next-event
 }
 
-DEVPATH is set, SUBSYSTEM ~~ (input) {
+DEVPATH is set, SUBSYSTEM == input {
 	makedev /dev/input/%DEVICENAME% 0644
 }
 
@@ -36,7 +36,6 @@ DEVICENAME == device-mapper {
 	makedev /dev/mapper/control 0600
 }
 
-
 DEVPATH is set {
 	makedev /dev/%DEVICENAME% 0644
 }
diff --git a/package/base-files/files/etc/hotplug2-init.rules b/package/base-files/files/etc/hotplug2-init.rules
index e7dd0add3b..f011697766 100644
--- a/package/base-files/files/etc/hotplug2-init.rules
+++ b/package/base-files/files/etc/hotplug2-init.rules
@@ -1,5 +1,5 @@
 $include /etc/hotplug2-common.rules
 
-SUBSYSTEM ~~ button {
+SUBSYSTEM == button {
 	exec kill -USR1 1
 }
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index a4ff850ad9..de46332500 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=hotplug2
 PKG_REV:=201
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
diff --git a/package/hotplug2/files/hotplug2.rules b/package/hotplug2/files/hotplug2.rules
index 9800658983..a7a4730105 100644
--- a/package/hotplug2/files/hotplug2.rules
+++ b/package/hotplug2/files/hotplug2.rules
@@ -1,10 +1,10 @@
 $include /etc/hotplug2-common.rules
 
-SUBSYSTEM ~~ (net|input|button|usb|platform|ieee1394|block|atm) {
+SUBSYSTEM ~~ (^net$|^input$|^button$|^usb$|^platform$|^ieee1394$|^block$|^atm$) {
 	exec /sbin/hotplug-call %SUBSYSTEM%
 }
 
-DEVICENAME ~~ (watchdog) {
+DEVICENAME == watchdog {
 	exec /sbin/watchdog -t 5 /dev/watchdog
-	next
+	next-event
 }