From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 3 Apr 2008 13:51:14 +0000 (+0000)
Subject: Make sure we will build USB hid support
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=825915f38ff84f8f9c64ffc6db491a281cfbce91;p=openwrt%2Fstaging%2Fdangole.git

Make sure we will build USB hid support

SVN-Revision: 10719
---

diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index f3035f4727..bfe14f642d 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -563,7 +563,7 @@ $(eval $(call KernelPackage,usb-net-cdc-ether))
 define KernelPackage/usb-hid
   $(call usbdep,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
   TITLE:=Support for USB Human Input Devices
-  KCONFIG:=CONFIG_USB_HID
+  KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID
   FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
   AUTOLOAD:=$(call AutoLoad,70,usbhid)
 endef