From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 24 Jul 2013 12:38:09 +0000 (+0000)
Subject: uClibc: build with debug symbols by default (without changing other compile related... 
X-Git-Tag: reboot~9712
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=82e51044d86fe28a4bc3d755b054cccc4014d8db;p=openwrt%2Fstaging%2Fpepe2k.git

uClibc: build with debug symbols by default (without changing other compile related flags)

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37525
---

diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index dec4a1c741..f0a5b3d84f 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -51,7 +51,7 @@ CPU_CFLAGS = \
 	-funsigned-char -fno-builtin -fno-asm \
 	--std=gnu99 -ffunction-sections -fdata-sections \
 	-Wno-unused-but-set-variable \
-	$(TARGET_CFLAGS)
+	$(TARGET_CFLAGS) -ggdb
 
 UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
 	$(TARGET_CONFIGURE_OPTS) \