From: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Date: Wed, 25 Nov 2020 14:48:40 +0000 (+0100)
Subject: build: uImage: separate arguments into individual lines
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8416d0626f57ff3303a44a7b9e29f97c3e380e63;p=openwrt%2Fstaging%2Fdedeckeh.git

build: uImage: separate arguments into individual lines

Having one line per argument increases overview dramatically.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---

diff --git a/include/image-commands.mk b/include/image-commands.mk
index a8faefbcff..de4c86c24a 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -394,11 +394,16 @@ define Build/tplink-v2-image
 endef
 
 define Build/uImage
-	mkimage -A $(LINUX_KARCH) \
-		-O linux -T kernel \
-		-C $(word 1,$(1)) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+	mkimage \
+		-A $(LINUX_KARCH) \
+		-O linux \
+		-T kernel \
+		-C $(word 1,$(1)) \
+		-a $(KERNEL_LOADADDR) \
+		-e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
 		-n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
-		$(wordlist 2,$(words $(1)),$(1)) -d $@ $@.new
+		$(wordlist 2,$(words $(1)),$(1)) \
+		-d $@ $@.new
 	mv $@.new $@
 endef