From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 23 Jan 2010 15:12:57 +0000 (+0000)
Subject: hostapd: fix compile error in the roboswitch driver
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8499c45a7355570239f1d54b05803f42a8989644;p=openwrt%2Fstaging%2Flinusw.git

hostapd: fix compile error in the roboswitch driver

SVN-Revision: 19290
---

diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 95b34141e7..93392110ab 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -54,7 +54,6 @@ DRIVER_MAKEOPTS= \
 	CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
 	CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
 	CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
-	CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch) \
 	CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
 
 ifeq ($(LOCAL_TYPE),supplicant)
@@ -66,6 +65,8 @@ endif
 ifneq ($(LOCAL_TYPE),hostapd)
   ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
     TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
+    DRIVER_MAKEOPTS += \
+		CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
   endif
 endif
 
diff --git a/package/hostapd/patches/340-roboswitch_fix.patch b/package/hostapd/patches/340-roboswitch_fix.patch
new file mode 100644
index 0000000000..50dca64f1a
--- /dev/null
+++ b/package/hostapd/patches/340-roboswitch_fix.patch
@@ -0,0 +1,14 @@
+--- a/src/drivers/driver_roboswitch.c
++++ b/src/drivers/driver_roboswitch.c
+@@ -14,10 +14,10 @@
+ 
+ #include "includes.h"
+ #include <sys/ioctl.h>
+-#include <linux/if.h>
+ #include <linux/sockios.h>
+ #include <linux/if_ether.h>
+ #include <linux/mii.h>
++#include <net/if.h>
+ 
+ #include "common.h"
+ #include "driver.h"