From: Florian Fainelli <florian@openwrt.org>
Date: Fri, 20 Feb 2009 10:19:24 +0000 (+0000)
Subject: include revision number in Ubiquity images
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8599641c8ff99f95dfb5bdee4c00533c9c607666;p=openwrt%2Fstaging%2Fdangole.git

include revision number in Ubiquity images

SVN-Revision: 14574
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3f0cd01c75..a48d5306d2 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -71,7 +71,7 @@ define Image/Build/UBNT
 	$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).lzma
 	dd if=$(KDIR)/vmlinux-$(2).lzma of=$(KDIR)/vmlinux-$(2).bin.lzma bs=64k conv=sync
 	-$(STAGING_DIR_HOST)/bin/mkfwimage \
-		-B $(4) -v $(5).ar7100.OpenWrt \
+		-B $(4) -v $(5).ar7100.OpenWrt.$(REVISION) \
 		-k $(KDIR)/vmlinux-$(2).bin.lzma \
 		-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
 		-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(2)-$(1).bin
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 45b72c7a87..73657334ee 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -24,13 +24,13 @@ define Image/Build
 	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
 
 	-$(STAGING_DIR_HOST)/bin/mkfwimage \
-		-B XS2 -v XS2.ar2316.OpenWrt \
+		-B XS2 -v XS2.ar2316.OpenWrt.$(REVISION) \
 		-k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
 		-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
 		-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
 
 	-$(STAGING_DIR_HOST)/bin/mkfwimage \
-		-B XS5 -v XS5.ar2313.OpenWrt \
+		-B XS5 -v XS5.ar2313.OpenWrt.$(REVISION) \
 		-k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
 		-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
 		-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin