From: Gabor Juhos <juhosg@openwrt.org>
Date: Tue, 24 Jan 2012 18:40:33 +0000 (+0000)
Subject: ar71xx: pass mtdlayout to Planex boards via command line
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=859c9150777f651e8b9dcf1a770380df1f439acb;p=openwrt%2Fstaging%2Fneocturne.git

ar71xx: pass mtdlayout to Planex boards via command line

SVN-Revision: 29894
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index dc433e0511..7013730903 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -291,8 +291,9 @@ define Image/Build/UBNT
   $(call sysupname,$(1),$(2))
 endef
 
+planex_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),6336k(rootfs),128k(art)ro,7744k@0x50000(firmware)
 define Image/Build/Planex
-	$(call MkuImageGzip,$(2),$(3))
+	$(call MkuImageGzip,$(2),$(3) $(planex_mtdlayout))
 	$(call Sysupgrade/KR,$(1),$(2),1441792,6356992)
 	if [ -e "$(call sysupname,$(1),$(2))" ]; then \
 		$(STAGING_DIR_HOST)/bin/mkplanexfw \