From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 8 May 2012 13:30:54 +0000 (+0000)
Subject: add further countermeasures against the git core.autocrlf option (fixes #9075)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=85f1a2c67a7b20d28d950a4e595ef172cb28d156;p=openwrt%2Fstaging%2Fdangole.git

add further countermeasures against the git core.autocrlf option (fixes #9075)

SVN-Revision: 31650
---

diff --git a/include/toplevel.mk b/include/toplevel.mk
index 9a60139329..721d14c486 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -24,6 +24,7 @@ export OPENWRTVERSION
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
+export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
 
 # prevent perforce from messing with the patch utility
 unexport P4PORT P4USER P4CONFIG P4CLIENT
diff --git a/scripts/feeds b/scripts/feeds
index b8c6825ed0..2c0baa6584 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -10,6 +10,7 @@ use Cwd 'abs_path';
 
 chdir "$FindBin::Bin/..";
 $ENV{TOPDIR}=getcwd();
+$ENV{GIT_CONFIG_PARAMETERS}="'core.autocrlf=false'";
 
 my $mk=`which gmake`;	# select the right 'make' program
 chomp($mk);		# trim trailing newline