From: Henryk Heisig <hyniu@o2.pl>
Date: Fri, 5 May 2017 15:07:28 +0000 (+0200)
Subject: ramips: add factory firmware for Tp-Link C20i/C50
X-Git-Tag: v17.01.2~62
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=86196830371c07c2b5721002f2ad500ca893076e;p=openwrt%2Fstaging%2Fxback.git

ramips: add factory firmware for Tp-Link C20i/C50

TP-Link firmware doesn't accept sysupgrade.bin with metadata.

Signed-off-by: Henryk Heisig <hyniu@o2.pl>
---

diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 42745c4109..e27c405b3c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -37,7 +37,9 @@ define Device/ArcherC20i
   SUPPORTED_DEVICES := c20i
   KERNEL := $(KERNEL_DTB)
   KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
+  IMAGE/factory.bin := append-kernel | tplink-header ArcherC20i -j
   IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
+  IMAGES += factory.bin
   DEVICE_TITLE := TP-Link ArcherC20i
 endef
 TARGET_DEVICES += ArcherC20i
@@ -47,7 +49,9 @@ define Device/ArcherC50
   SUPPORTED_DEVICES := c50
   KERNEL := $(KERNEL_DTB)
   KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
+  IMAGE/factory.bin := append-kernel | tplink-header ArcherC50 -j
   IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata
+  IMAGES += factory.bin
   DEVICE_TITLE := TP-Link ArcherC50
 endef
 TARGET_DEVICES += ArcherC50