From: Imre Kaloz <kaloz@openwrt.org>
Date: Fri, 6 Feb 2015 11:18:59 +0000 (+0000)
Subject: mvebu: add note about the move to single firmware files
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=865647cea2b00c6cc13b790a98d8808ff9f9fb9a;p=openwrt%2Fsvn-archive%2Fopenwrt.git

mvebu: add note about the move to single firmware files

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>

SVN-Revision: 44291
---

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 5d677f95a9..3512c6a3b6 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -22,6 +22,7 @@ define Image/Build/DTB
 	$(call Image/BuildKernel/MkuImage, \
 		none, $(LOADADDR), $(LOADADDR), \
 		$(KDIR)/zImage$(2)-$(1), $(KDIR)/uImage$(2)-$(1))
+# The next line will be dropped, migrate your board to use a single firmware file
 	cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
 endef
 
@@ -48,6 +49,7 @@ define NANDProfile
 
   define Image/Build/Profile/$(1)/squashfs
 	$(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m $(4) $(if $(5),-s $(5)))
+# The next line will be dropped, migrate your board to use a single firmware file
 	cp $(KDIR)/$$(IMG_PREFIX)-$(2)-squashfs-ubinized.bin $(BIN_DIR)
   endef
 
@@ -167,6 +169,7 @@ endef
 
 define Image/Build
 	$(call Image/Build/$(1))
+# The next line will be dropped, migrate your board to use a single firmware file
 	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 	$(call Image/Build/Profile/$(PROFILE)/BuildSysupgrade,$(1))
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)