From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 24 Oct 2020 21:34:18 +0000 (+0200)
Subject: gdb: Always use system zlib
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8698a727ddf2f7bdfc0d1d084688be85ee42eb9f;p=openwrt%2Fstaging%2Fjogo.git

gdb: Always use system zlib

Instead of using the system zlib when the package is selected and using
the internal zlib if it is not selected in OpenWrt, just activate it
always. This should make the package more deterministic.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
index 9817599558..50d43e9fc1 100644
--- a/package/devel/gdb/Makefile
+++ b/package/devel/gdb/Makefile
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/gdb/Default
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=+!USE_MUSL:libthread-db +PACKAGE_zlib:zlib
+  DEPENDS:=+!USE_MUSL:libthread-db +zlib
   URL:=https://www.gnu.org/software/gdb/
 endef
 
@@ -55,6 +55,7 @@ endef
 # XXX: add --disable-werror to prevent build failure with arm
 CONFIGURE_ARGS+= \
 	--with-system-readline \
+	--with-system-zlib \
 	--without-expat \
 	--without-lzma \
 	--disable-sim \