From: Gabor Juhos <juhosg@openwrt.org>
Date: Sat, 28 Apr 2012 10:39:47 +0000 (+0000)
Subject: adm8668: nuke 2.6.36 support
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=87ae19eaa3c7149c42c85ad9c04f2c737b54d991;p=openwrt%2Fstaging%2Fansuel.git

adm8668: nuke 2.6.36 support

SVN-Revision: 31496
---

diff --git a/target/linux/adm8668/config-2.6.36 b/target/linux/adm8668/config-2.6.36
deleted file mode 100644
index 20cfcf7e2f..0000000000
--- a/target/linux/adm8668/config-2.6.36
+++ /dev/null
@@ -1,36 +0,0 @@
-CONFIG_ADM8668=y
-CONFIG_CEVT_R4K=y
-CONFIG_CEVT_R4K_LIB=y
-CONFIG_CPU_HAS_PREFETCH=y
-CONFIG_CPU_HAS_SYNC=y
-CONFIG_CPU_LITTLE_ENDIAN=y
-CONFIG_CPU_MIPS32=y
-CONFIG_CPU_MIPS32_R1=y
-CONFIG_CPU_MIPSR1=y
-CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
-CONFIG_CPU_SUPPORTS_HIGHMEM=y
-CONFIG_CSRC_R4K=y
-CONFIG_CSRC_R4K_LIB=y
-CONFIG_DECOMPRESS_LZMA=y
-CONFIG_DMA_NONCOHERENT=y
-CONFIG_EEPROM_93CX6=m
-CONFIG_HAS_DMA=y
-CONFIG_HAS_IOMEM=y
-CONFIG_HAS_IOPORT=y
-CONFIG_HW_HAS_PCI=y
-CONFIG_IRQ_CPU=y
-CONFIG_MIPS=y
-CONFIG_MIPS_L1_CACHE_SHIFT=5
-CONFIG_MIPS_MT_DISABLED=y
-CONFIG_MTD_ADM8668_NOR=y
-CONFIG_NEED_DMA_MAP_STATE=y
-CONFIG_PCI=y
-CONFIG_PCI_DOMAINS=y
-CONFIG_SERIAL_ADM8668=y
-CONFIG_SERIAL_ADM8668_CONSOLE=y
-CONFIG_SWAP_IO_SPACE=y
-CONFIG_SYS_HAS_CPU_MIPS32_R1=y
-CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
-CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
-CONFIG_SYS_SUPPORTS_LITTLE_ENDIAN=y
-CONFIG_ZONE_DMA_FLAG=0
diff --git a/target/linux/adm8668/patches-2.6.36/001-adm8668_arch.patch b/target/linux/adm8668/patches-2.6.36/001-adm8668_arch.patch
deleted file mode 100644
index 81cac43d4b..0000000000
--- a/target/linux/adm8668/patches-2.6.36/001-adm8668_arch.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/arch/mips/Kbuild.platforms	2010-10-20 16:30:22.000000000 -0400
-+++ b/arch/mips/Kbuild.platforms	2010-10-22 08:42:06.228968083 -0400
-@@ -27,6 +27,7 @@
- platforms += txx9
- platforms += vr41xx
- platforms += wrppmc
-+platforms += adm8668
-
- # include the platform specific files
- include $(patsubst %, $(srctree)/arch/mips/%/Platform, $(platforms))
---- a/arch/mips/Kconfig	2010-10-20 16:30:22.000000000 -0400
-+++ b/arch/mips/Kconfig	2010-10-22 08:37:31.016965108 -0400
-@@ -82,6 +82,24 @@
- 	help
- 	 Support for BCM47XX based boards
-
-+config ADM8668
-+	bool "WildPass ADM8668"
-+	select SYS_HAS_CPU_MIPS32_R1
-+	select IRQ_CPU
-+	select CEVT_R4K
-+	select CSRC_R4K
-+	select HW_HAS_PCI
-+	select PCI
-+	select SYS_SUPPORTS_LITTLE_ENDIAN
-+	select SYS_SUPPORTS_32BIT_KERNEL
-+	select DMA_NONCOHERENT
-+	select SWAP_IO_SPACE
-+	select SERIAL_ADM8668
-+	select SERIAL_ADM8668_CONSOLE
-+	help
-+		ADM8668 board support by neutronscott
-+		Scott Nicholas <neutronscott@scottn.us>
-+
- config BCM63XX
- 	bool "Broadcom BCM63XX based boards"
- 	select CEVT_R4K
diff --git a/target/linux/adm8668/patches-2.6.36/002-adm8668_uart.patch b/target/linux/adm8668/patches-2.6.36/002-adm8668_uart.patch
deleted file mode 100644
index 44fcd29de3..0000000000
--- a/target/linux/adm8668/patches-2.6.36/002-adm8668_uart.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/drivers/serial/Kconfig
-+++ b/drivers/serial/Kconfig
-@@ -1510,6 +1510,25 @@
- 	  If you have enabled the serial port on the bcm63xx CPU
- 	  you can make it the console by answering Y to this option.
-
-+config SERIAL_ADM8668
-+	tristate "ADM8668 serial port support"
-+	select SERIAL_CORE
-+	depends on ADM8668
-+	help
-+	  If you have an adm8668 CPU, you can enable its onboard
-+	  serial port by enabling this options.
-+
-+          To compile this driver as a module, choose M here: the
-+          module will be called adm8668_uart.
-+
-+config SERIAL_ADM8668_CONSOLE
-+	bool "Console on adm8668 serial port"
-+	depends on SERIAL_ADM8668=y
-+	select SERIAL_CORE_CONSOLE
-+	help
-+	  If you have enabled the serial port on the adm8668 CPU
-+	  you can make it the console by answering Y to this option.
-+
- config SERIAL_GRLIB_GAISLER_APBUART
- 	tristate "GRLIB APBUART serial support"
- 	depends on OF
---- a/include/linux/serial_core.h
-+++ b/include/linux/serial_core.h
-@@ -196,6 +196,9 @@
- /* High Speed UART for Medfield */
- #define PORT_MFD	95
-
-+/* ADM8668 UART */
-+#define	PORT_ADM8668	93
-+
- #ifdef __KERNEL__
-
- #include <linux/compiler.h>
-
diff --git a/target/linux/adm8668/patches-2.6.36/003-adm8668_nor_map.patch b/target/linux/adm8668/patches-2.6.36/003-adm8668_nor_map.patch
deleted file mode 100644
index 59fba583e0..0000000000
--- a/target/linux/adm8668/patches-2.6.36/003-adm8668_nor_map.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/mtd/maps/Kconfig
-+++ b/drivers/mtd/maps/Kconfig
-@@ -103,6 +103,12 @@
- 	default "0x02000000"
- 	depends on MSP_FLASH_MAP_LIMIT_32M
-
-+config MTD_ADM8668_NOR
-+	tristate "ADM8668 NOR mapping"
-+	depends on ADM8668 && MTD_CFI
-+	help
-+	  mapping driver for ADM8668 NOR
-+
- config MTD_SUN_UFLASH
- 	tristate "Sun Microsystems userflash support"
- 	depends on SPARC && MTD_CFI && PCI
---- a/drivers/mtd/maps/Makefile
-+++ b/drivers/mtd/maps/Makefile
-@@ -7,6 +7,7 @@
- endif
-
- # Chip mappings
-+obj-$(CONFIG_MTD_ADM8668_NOR)	+= adm8668.o
- obj-$(CONFIG_MTD_CDB89712)	+= cdb89712.o
- obj-$(CONFIG_MTD_ARM_INTEGRATOR)+= integrator-flash.o
- obj-$(CONFIG_MTD_CFI_FLAGADM)	+= cfi_flagadm.o