From: Thomas Fuzeau <tfuzeau@loocla.com>
Date: Tue, 30 Oct 2018 11:06:22 +0000 (+0100)
Subject: kernel: add kmod-usb-serial-mos7840
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=87e1894d59bf2272e93ae26692eefc9826997709;p=openwrt%2Fstaging%2Fnbd.git

kernel: add kmod-usb-serial-mos7840

Enable build of kernel module for mos7840 usb-serial devices.

Signed-off-by: Thomas Fuzeau <tfuzeau@loocla.com>
---

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 61a876b4d9..748e7ede84 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -738,6 +738,21 @@ endef
 $(eval $(call KernelPackage,usb-serial-mos7720))
 
 
+define KernelPackage/usb-serial-mos7840
+  TITLE:=Support for Moschip MOS7840 devices
+  KCONFIG:=CONFIG_USB_SERIAL_MOS7840
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/mos7840.ko
+  AUTOLOAD:=$(call AutoProbe,mos7840)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-mos7840/description
+ Kernel support for Moschip MOS7840 USB-to-Serial converters
+endef
+
+$(eval $(call KernelPackage,usb-serial-mos7840))
+
+
 define KernelPackage/usb-serial-pl2303
   TITLE:=Support for Prolific PL2303 devices
   KCONFIG:=CONFIG_USB_SERIAL_PL2303