From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 3 Mar 2009 15:08:55 +0000 (+0000)
Subject: optimize the .config dependency chain in the toplevel makefile
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=88f6e9f9fde6947ba556bf821869a159a2b98f69;p=openwrt%2Fstaging%2Fdangole.git

optimize the .config dependency chain in the toplevel makefile

SVN-Revision: 14740
---

diff --git a/include/toplevel.mk b/include/toplevel.mk
index 7f5308fc26..9dfc9dfc2f 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -49,7 +49,7 @@ prepare-tmpinfo: FORCE
 	./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
 	touch $(TOPDIR)/tmp/.build
 
-.config: ./scripts/config/conf prepare-tmpinfo $(if $(CONFIG_HAVE_DOT_CONFIG),,FORCE)
+.config: ./scripts/config/conf $(if $(CONFIG_HAVE_DOT_CONFIG),,prepare-tmpinfo)
 	@+if [ \! -e .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
 		[ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
 		$(_SINGLE)$(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
@@ -106,7 +106,7 @@ download: .config FORCE
 clean dirclean: .config
 	@+$(SUBMAKE) -r $@ 
 
-prereq:: .config
+prereq:: prepare-tmpinfo .config
 	@+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
 	@+$(NO_TRACE_MAKE) -r -s $@