From: John Crispin <john@openwrt.org>
Date: Wed, 20 Apr 2016 17:19:05 +0000 (+0000)
Subject: ramips: fix support Planex MZK-750DHP.
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=890eb0c126f21620ddf81ceff5a2480395b8651b;p=openwrt%2Fstaging%2Fjow.git

ramips: fix support Planex MZK-750DHP.

fix script for Planex MZK-750DHP.
modification of the GPIO definition.
add Profile.

Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com>

SVN-Revision: 49205
---

diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 5816e60f66..2f40955d11 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -122,6 +122,7 @@ dir-620-d1)
 	set_wifi_led "$board:green:wifi"
 	;;
 dir-810l|\
+mzk-750dhp|\
 mzk-dp150n)
 	ucidef_set_led_default "power" "power" "$board:green:power" "1"
 	;;
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index daa7fb1afd..a2c965d79d 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -21,6 +21,7 @@ get_status_led() {
 	br-6475nd|\
 	e1700|\
 	fonera20n|\
+	mzk-750dhp|\
 	mzk-dp150n|\
 	mzk-w300nh2|\
 	nbg-419n|\
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index c329dce4f7..cbeda7accb 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -86,6 +86,7 @@ platform_check_image() {
 	mpr-a2|\
 	mr-102n|\
 	mt7628|\
+	mzk-750dhp|\
 	mzk-dp150n|\
 	mzk-w300nh2|\
 	mzk-wdpr|\
diff --git a/target/linux/ramips/dts/MZK-750DHP.dts b/target/linux/ramips/dts/MZK-750DHP.dts
index df0b73be95..5947a54022 100644
--- a/target/linux/ramips/dts/MZK-750DHP.dts
+++ b/target/linux/ramips/dts/MZK-750DHP.dts
@@ -11,6 +11,10 @@
 			status = "okay";
 		};
 
+		gpio2: gpio@660 {
+			status = "okay";
+		};
+
 		spi@b00 {
 			status = "okay";
 
@@ -51,7 +55,7 @@
 	pinctrl {
 		state_default: pinctrl0 {
 			gpio {
-				ralink,group = "i2c", "spi refclk", "rgmii1";
+				ralink,group = "i2c", "spi refclk", "rgmii1", "nd_sd";
 				ralink,function = "gpio";
 			};
 		};
@@ -74,6 +78,15 @@
 
 	pcie@10140000 {
 		status = "okay";
+
+		pcie-bridge {
+			mt76@0,0 {
+				reg = <0x0000 0 0 0 0>;
+				device_type = "pci";
+				mediatek,mtd-eeprom = <&factory 0x8000>;
+				mediatek,2ghz = <0>;
+			};
+		};
 	};
 	
 	gpio-leds {
@@ -81,13 +94,18 @@
 
 		wps {
 			label = "mzk-750dhp:green:wps";
-			gpios = <&gpio1 11 1>;
+			gpios = <&gpio2 15 1>;
 		};
 
 		power {
 			label = "mzk-750dhp:green:power";
 			gpios = <&gpio1 15 1>;
 		};
+
+		wlan5g {
+			label = "mzk-750dhp:green:wlan5g";
+			gpios = <&gpio1 14 1>;
+		};
 	};
 
 	gpio-keys-polled {
@@ -99,12 +117,12 @@
 		s1 {
 			label = "reset";
 			gpios = <&gpio0 1 1>;
-			linux,code = <0x100>;
+			linux,code = <0x198>;
 		};
 
 		s2 {
 			label = "wps";
-			gpios = <&gpio0 2 1>;
+			gpios = <&gpio2 19 1>;
 			linux,code = <0x211>;
 		};
 	};
diff --git a/target/linux/ramips/mt7620/profiles/planex.mk b/target/linux/ramips/mt7620/profiles/planex.mk
new file mode 100644
index 0000000000..f6f2cf187c
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/planex.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MZK-750DHP
+	NAME:=Planex MZK-750DHP
+	PACKAGES:= kmod-mt76 kmod-mt7610e
+endef
+
+define Profile/MZK-750DHP/Description
+	Package set optimized for the Planex MZK-750DHP.
+endef
+$(eval $(call Profile,MZK-750DHP))