From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 15 Jun 2008 14:34:00 +0000 (+0000)
Subject: add some sanity checking
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8b41afa584e513ec64156fc15058a0f6888d6b56;p=openwrt%2Fstaging%2Fdangole.git

add some sanity checking

SVN-Revision: 11473
---

diff --git a/include/toplevel.mk b/include/toplevel.mk
index 606e3e5844..e13d66781a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -45,7 +45,7 @@ prepare-tmpinfo: FORCE
 	touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf prepare-tmpinfo
-	@+if [ \! -f .config ]; then \
+	@+if [ -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
 		[ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
 		$(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
 	fi
diff --git a/toolchain/Makefile b/toolchain/Makefile
index cbc726ef01..4afcc439a3 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -23,7 +23,8 @@ ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   $(curdir)/uClibc/install:=$(curdir)/gcc/install
 endif
 
-$(TOOLCHAIN_DIR)/info.mk: .config
+ifneq ($(ARCH),)
+  $(TOOLCHAIN_DIR)/info.mk: .config
 	@for dir in $(TOOLCHAIN_DIR); do ( \
 		set -x; \
 		mkdir -p "$$dir"; \
@@ -32,6 +33,7 @@ $(TOOLCHAIN_DIR)/info.mk: .config
 	); done
 	@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
 	@touch $@
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq