From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 11 Jun 2016 14:14:52 +0000 (+0200)
Subject: lantiq: build fullimage.img for EASY80920NAND
X-Git-Tag: v17.01.0-rc1~2278
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8bfa230e9fcdc197f3a9652befbb28e9771533f9;p=openwrt%2Fstaging%2Fchunkeey.git

lantiq: build fullimage.img for EASY80920NAND

This image format is used by Lantiq's / Intel's UGW version 6.1 to 7.1.
These images can be flashed onto a board with the SoC vendor boot
loader as a replacement for the vendor firmware.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index ff29b2aa78..e0a28c227f 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -188,6 +188,21 @@ define Build/mkbrnimg
    mkbrnimg -s $(SIGNATURE) -m $(MAGIC) -p $(CRC32_POLY) -o $@ $(word 1,$^) $(word 2,$^)
 endef
 
+define Build/fullimage
+	mkimage -A mips -O linux -C lzma -T filesystem -a 0x00  \
+		-e 0x00 -n 'LEDE RootFS' \
+		-d $(word 2,$^) $(word 2,$^).new
+
+	cat $(word 1,$^) $(word 2,$^).new > $@.tmp
+
+	mkimage -A mips -O linux -T multi -a 0x00 -C none \
+		-e 0x00 -n 'OpenWrt fullimage' \
+		-d $@.tmp $@
+
+	rm $(word 2,$^).new
+	rm $@.tmp
+endef
+
 # Shared device definition: applies to every defined device
 define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
@@ -211,6 +226,12 @@ define Device/lantiqBrnImage
 endef
 DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
 
+define Device/lantiqFullImage
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-offset 4 0
+  IMAGES := sysupgrade.bin fullimage.img
+  IMAGE/fullimage.img := fullimage | check-size $$$$(IMAGE_SIZE)
+endef
+
 ifeq ($(SUBTARGET),xway_legacy)
 
 define Device/ARV4520PW
@@ -628,6 +649,7 @@ endef
 LEGACY_DEVICES += BTHOMEHUBV5A
 
 define Device/EASY80920NAND
+  $(Device/lantiqFullImage)
   DEVICE_PROFILE := EASY80920NAND
   IMAGE_SIZE := 64512k
   DEVICE_TITLE := Lantiq VR9 - EASY80920NAND