From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 2 Nov 2015 18:12:23 +0000 (+0000)
Subject: iproute2: always use -DHAVE_SETNS, since the old uclibc is gone now
X-Git-Tag: reboot~1661
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8ca8fd757ab5c55b61bd141f8dba4e21c8ede0c3;p=openwrt%2Fstaging%2Fjogo.git

iproute2: always use -DHAVE_SETNS, since the old uclibc is gone now

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 47358
---

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index f5b5f4e536..e5015dbdfc 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -78,16 +78,7 @@ define Build/Configure
 		> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
 endef
 
-ifdef CONFIG_USE_GLIBC
-  TARGET_CFLAGS += -DHAVE_SETNS
-endif
-ifdef CONFIG_USE_MUSL
-  TARGET_CFLAGS += -DHAVE_SETNS
-endif
-ifdef CONFIG_UCLIBC_USE_VERSION_NG
-  TARGET_CFLAGS += -DHAVE_SETNS
-endif
-
+TARGET_CFLAGS += -DHAVE_SETNS
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
 MAKE_FLAGS += \