From: Mazi Lo <openwrt.mazilo@recursor.net>
Date: Tue, 28 Oct 2014 06:25:39 +0000 (-0400)
Subject: FreeSWITCH:
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8d0e8f3638b671d4aae22b5f2227b4e1749308cd;p=feed%2Ftelephony.git

FreeSWITCH:

1. Some platforms failed in configure process while checking for working
PROCESS_SHARED locks. Perhaps, this is caused by apr_cv_process_shared_works
variable set to yes in configure.ac file. This commit will set the
variable to no and see if configure process will pass such test.

Signed-off-by: Mazi Lo <openwrt.mazilo@recursor.net>
---

diff --git a/net/freeswitch/patches/0000010-configure_ac.patch b/net/freeswitch/patches/0000010-configure_ac.patch
index 02d050e..2bc11fa 100644
--- a/net/freeswitch/patches/0000010-configure_ac.patch
+++ b/net/freeswitch/patches/0000010-configure_ac.patch
@@ -18,6 +18,15 @@
  		# rpl_malloc
  		export ac_cv_func_realloc_0_nonnull=yes
  		export ac_cv_func_malloc_0_nonnull=yes
+@@ -248,7 +251,7 @@ if test "x${cross_compiling}" = "xyes";
+ 		export apr_cv_mutex_recursive=yes
+ 		export ac_cv_func_pthread_rwlock_init=yes
+ 		export apr_cv_type_rwlock_t=yes
+-		export apr_cv_process_shared_works=yes
++		export apr_cv_process_shared_works=no
+ 		export apr_cv_mutex_robust_shared=yes
+ 	 ;;
+     esac
 @@ -378,9 +381,6 @@ elif test "x${ax_cv_c_compiler_vendor}"
  elif test "x${ax_cv_c_compiler_vendor}" = "xgnu" ; then
      APR_ADDTO(SWITCH_AM_CFLAGS, -fPIC)