From: Mirko Vogt <mirko@openwrt.org>
Date: Fri, 17 Jun 2011 22:51:20 +0000 (+0000)
Subject: link against 'libbsd' when using glibc
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8d48672c109beb1a9cf515aea7c99c10af85f672;p=openwrt%2Fstaging%2Faparcar.git

link against 'libbsd' when using glibc

SVN-Revision: 27209
---

diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 9625ba27f9..699976e8a9 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -28,7 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
-  DEPENDS:=+USE_EGLIBC:libbsd
+  DEPENDS:=+USE_EGLIBC:libbsd +USE_GLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
 	COPTS="$(TARGET_CFLAGS)" \
 	STATIC_WORKER="fork"
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
   TARGET_LDFLAGS += -lbsd
 endif