From: Matthias Schiffer <mschiffer@universe-factory.net>
Date: Tue, 5 Jun 2018 22:27:42 +0000 (+0200)
Subject: ar71xx: lzma-loader: set page size to 4KB
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8d851a95b7f581a844160b892e0e52b9bb5b9a68;p=openwrt%2Fstaging%2Fjogo.git

ar71xx: lzma-loader: set page size to 4KB

The text section in the ELF loader is aligned to the maximum page size,
which defaults to 64KB. Reduce it to the actual page size to avoid wasting
flash space for this alignment.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
---

diff --git a/target/linux/ar71xx/image/lzma-loader/src/Makefile b/target/linux/ar71xx/image/lzma-loader/src/Makefile
index c54f64a550..7773f027a2 100644
--- a/target/linux/ar71xx/image/lzma-loader/src/Makefile
+++ b/target/linux/ar71xx/image/lzma-loader/src/Makefile
@@ -97,7 +97,7 @@ loader2.o: loader.bin
 	$(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
 
 loader.elf: loader2.o
-	$(LD) -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
+	$(LD) -z max-page-size=0x1000 -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
 
 mrproper: clean