From: Jonas Gorski <jogo@openwrt.org>
Date: Thu, 18 Jul 2013 11:29:18 +0000 (+0000)
Subject: build: print missing dependency error to stderr
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8e12b39d5dc565df2780f46f615129885439d5fa;p=openwrt%2Fstaging%2Fansuel.git

build: print missing dependency error to stderr

Allow to see the actual error even when compiling with V=w/V=1 only.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 37388
---

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 696de156cf..522a1de15f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -64,8 +64,8 @@ ifneq ($(PKG_NAME),toolchain)
 				echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
 		done; \
 		if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \
-			echo "Package $(1) is missing dependencies for the following libraries:"; \
-			cat "$(PKG_INFO_DIR)/$(1).missing"; \
+			echo "Package $(1) is missing dependencies for the following libraries:" >&2; \
+			cat "$(PKG_INFO_DIR)/$(1).missing" >&2; \
 			false; \
 		fi; \
 	)