From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 5 Feb 2015 23:18:47 +0000 (+0000)
Subject: mac80211: don't hardcode /bin/bash
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=8f7ce3aa6ddaa94eb1fa1fca47f1f6b34b839412;p=openwrt%2Fsvn-archive%2Fopenwrt.git

mac80211: don't hardcode /bin/bash

Instead of hardcoding /bin/bash, use /usr/bin/env bash - this fixes the
build on FreeBSD 10.1.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 44283
---

diff --git a/package/kernel/mac80211/patches/001-fix_build.patch b/package/kernel/mac80211/patches/001-fix_build.patch
index 99ef50e182..3c3efdd5a1 100644
--- a/package/kernel/mac80211/patches/001-fix_build.patch
+++ b/package/kernel/mac80211/patches/001-fix_build.patch
@@ -1,5 +1,14 @@
 --- a/Makefile
 +++ b/Makefile
+@@ -5,7 +5,7 @@
+ ifeq ($(KERNELRELEASE),)
+ 
+ MAKEFLAGS += --no-print-directory
+-SHELL := /bin/bash
++SHELL := /usr/bin/env bash
+ BACKPORT_PWD := $(shell pwd)
+ 
+ KMODDIR ?= updates
 @@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/
  KERNEL_CONFIG := $(KLIB_BUILD)/.config
  KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile