From: Florian Fainelli <florian@openwrt.org>
Date: Mon, 5 Oct 2009 20:05:56 +0000 (+0000)
Subject: add kmod-input-rb532, driver for the rb532 user button
X-Git-Tag: reboot~22261
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=900e7fda797547614d146a21421c516be17c2866;p=openwrt%2Fstaging%2Fblogic.git

add kmod-input-rb532, driver for the rb532 user button

SVN-Revision: 17927
---

diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 1b8e533cdc53..58b0561bc6bb 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -724,6 +724,23 @@ endef
 
 $(eval $(call KernelPackage,input-joydev))
 
+define KernelPackage/input-rb532
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RB532 button device support
+  DEPENDS:=+kmod-input-core @TARGET_rb532
+  KCONFIG:= \
+	CONFIG_INPUT_MISC=y \
+	CONFIG_INPUT_RB532_BUTTON
+  FILES:=$(LINUX_DIR)/drivers/input/misc/rb532_button.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,62,rb532_button)
+endef
+
+define KernelPackage/input-rb532/description
+  Kernel module for RB532 button
+endef
+
+$(eval $(call KernelPackage,input-rb532))
+
 
 define KernelPackage/mmc-atmelmci
   SUBMENU:=$(OTHER_MENU)