From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 14 Jan 2008 12:28:53 +0000 (+0000)
Subject: add $(TOOLCHAIN_DIR)/lib to $(TARGET_LDFLAGS) to ensure that all packages process... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=903af2c13e1eb54358f5c88567aeee1eef9eee60;p=openwrt%2Fstaging%2Fjow.git

add $(TOOLCHAIN_DIR)/lib to $(TARGET_LDFLAGS) to ensure that all packages process this correctly - fixes build errors with openldap/php5

SVN-Revision: 10190
---

diff --git a/rules.mk b/rules.mk
index 7ac39b123e..da16ed4466 100644
--- a/rules.mk
+++ b/rules.mk
@@ -59,7 +59,7 @@ endif
 TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
 TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) -fhonour-copts
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
 ifeq ($(CONFIG_SOFT_FLOAT),y)
 SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft