From: John Crispin <john@openwrt.org>
Date: Mon, 6 Oct 2014 20:05:39 +0000 (+0000)
Subject: octeon: prepare elf kernel image and md5sum for usb copying
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=90cbc9a04fce0bee57bd7b2983e6ae570edfb189;p=openwrt%2Fstaging%2Fansuel.git

octeon: prepare elf kernel image and md5sum for usb copying

Signed-off-by: Roman Yeryomin <roman@advem.lv>

SVN-Revision: 42809
---

diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 25a81496b2..f06dd6bcfe 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -12,6 +12,8 @@ define Image/BuildKernel
 	$(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
 	$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
 	dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+	$(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/vmlinux.64
+	md5sum  $(BIN_DIR)/vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/vmlinux.64.md5
 endef
 
 define Image/Build/squashfs