From: Jo-Philipp Wich <jo@mein.io>
Date: Tue, 10 Jan 2017 15:25:10 +0000 (+0100)
Subject: build: scan.mk: consider KernelPackage pattern as well
X-Git-Tag: v17.01.0-rc1~161
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=90ed0aa859426d71fb71cf5df3646208d5f48e6e;p=openwrt%2Fstaging%2Fchunkeey.git

build: scan.mk: consider KernelPackage pattern as well

The removal of the ".+Package" pattern in scan.mk also caused the build
system to skip over Makefiles defining only kmods. Adjust the grep pattern
to consider packages with "call KernelPackage" signatures as well.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---

diff --git a/include/scan.mk b/include/scan.mk
index 9b361f8b3b..3a884fb5f5 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -51,7 +51,7 @@ $(OVERRIDELIST):
 ifeq ($(SCAN_NAME),target)
   GREP_STRING=BuildTarget
 else
-  GREP_STRING=(Build/DefaultTargets|BuildPackage)
+  GREP_STRING=(Build/DefaultTargets|BuildPackage|KernelPackage)
 endif
 
 $(FILELIST): $(OVERRIDELIST)