From: Oliver Ertl <oliver@ertl-net.net>
Date: Wed, 28 Dec 2005 10:23:37 +0000 (+0000)
Subject: add vnstat
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=9157b26a342064f736a8cd2cd38d94fd5a30f63a;p=openwrt%2Fstaging%2Flinusw.git

add vnstat

SVN-Revision: 2786
---

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 775653b717..bdf499ab09 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -138,6 +138,7 @@ source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
 source "package/vgp/Config.in"
 source "package/vnc-reflector/Config.in"
+source "package/vnstat/Config.in"
 source "package/vpnc/Config.in"
 source "package/vrrpd/Config.in"
 source "package/vsftpd/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 9439bf1e8e..7b1a7429e2 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -218,6 +218,7 @@ package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
 package-$(BR2_PACKAGE_UDEV) += udev
 package-$(BR2_PACKAGE_VGP) += vgp
 package-$(BR2_PACKAGE_VNC_REFLECTOR) += vnc-reflector
+package-$(BR2_PACKAGE_VNSTAT) += vnstat
 package-$(BR2_PACKAGE_VPNC) += vpnc
 package-$(BR2_PACKAGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
diff --git a/openwrt/package/vnstat/Config.in b/openwrt/package/vnstat/Config.in
new file mode 100644
index 0000000000..ab6a8dee35
--- /dev/null
+++ b/openwrt/package/vnstat/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_VNSTAT
+	prompt "vnstat............................ Console-based network traffic monitor"
+	tristate
+	default m if CONFIG_DEVEL
+	help
+	  vnStat is a network traffic monitor for Linux that keeps a log of daily
+	  network traffic for the selected interface(s). vnStat isn't a packet
+	  sniffer. The traffic information is analyzed from the /proc -filesystem,
+	  so vnStat can be used without root permissions.
+	  .
+	  http://humdi.net/vnstat/
diff --git a/openwrt/package/vnstat/Makefile b/openwrt/package/vnstat/Makefile
new file mode 100644
index 0000000000..4e1e4d6f7d
--- /dev/null
+++ b/openwrt/package/vnstat/Makefile
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vnstat
+PKG_VERSION:=1.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=9184f79b5e60499bc059f670032291e5
+
+PKG_SOURCE_URL:=http://humdi.net/vnstat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VNSTAT,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		$(TARGET_CONFIGURE_OPTS)
+	touch $@
+
+$(IPKG_VNSTAT):
+	install -d -m0755 $(IDIR_VNSTAT)/usr/bin
+	cp $(PKG_BUILD_DIR)/src/vnstat $(IDIR_VNSTAT)/usr/bin/
+	$(STRIP) $(IDIR_VNSTAT)/usr/bin/*
+	$(IPKG_BUILD) $(IDIR_VNSTAT) $(PACKAGE_DIR)
diff --git a/openwrt/package/vnstat/ipkg/vnstat.control b/openwrt/package/vnstat/ipkg/vnstat.control
new file mode 100644
index 0000000000..9d7ba79072
--- /dev/null
+++ b/openwrt/package/vnstat/ipkg/vnstat.control
@@ -0,0 +1,4 @@
+Package: vnstat
+Priority: optional
+Section: net
+Description: Console-based network traffic monitor