From: Imre Kaloz <kaloz@openwrt.org>
Date: Wed, 14 Jan 2015 11:37:29 +0000 (+0000)
Subject: mvebu: Replace the padjffs2 call by the generic definition
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=91b79128dc8f55a42818b775649ec893eb4f2fe8;p=openwrt%2Fsvn-archive%2Fopenwrt.git

mvebu: Replace the padjffs2 call by the generic definition

The mvebu image Makefile directly calls the padjffs2 utility, while there's an
generic make function to do just that. Switch to it

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>

SVN-Revision: 43968
---

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 92571e2153..f265dc43d2 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -44,7 +44,7 @@ define Image/BuildKernel
 endef
 
 define Image/Build/squashfs
-	$(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+	$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 	$(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
 	( \
 		dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \