From: Christian Lamparter <chunkeey@gmail.com>
Date: Mon, 15 Oct 2018 18:00:05 +0000 (+0200)
Subject: build: remove obsolete -rc kernel testing rewrites
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=92bcd08989dede0f60589023e2aea4a864de76c6;p=openwrt%2Fstaging%2Fansuel.git

build: remove obsolete -rc kernel testing rewrites

The -rcX "testing" kernels are no longer hosted on
cdn.kernel.org file servers directly in a "testing"
directory. Therefore the logic that tested for "-rc"
can be removed.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---

diff --git a/include/kernel.mk b/include/kernel.mk
index 77c5ecf600..62a8e99e2d 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -60,9 +60,8 @@ else
   LINUX_KERNEL:=$(KERNEL_BUILD_DIR)/vmlinux
 
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
-  TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
-      LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x$(TESTING)
+      LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x
   else
       LINUX_UNAME_VERSION:=$(strip $(shell cat $(LINUX_DIR)/include/config/kernel.release 2>/dev/null))
   endif