From: David Bauer <mail@david-bauer.net>
Date: Tue, 15 May 2018 23:57:16 +0000 (+0200)
Subject: ipq40xx: add eva-image for FRITZ!Box 4040
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=9361c359e4e1648f3ec3f541c51a1982d677f31d;p=openwrt%2Fstaging%2Fdedeckeh.git

ipq40xx: add eva-image for FRITZ!Box 4040

This commit adds an EVA flashable image for the FRITZ!Box 4040.

The image contains the U-Boot with OpenWRT appended to it. This way we
remove the need to use UART for initial flashing.

Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit 70e6ea319d3bfdfdb34be540dc7d89aa175b5587)
---

diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index be396f92da..8ba2697e4f 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -80,7 +80,10 @@ define Device/avm_fritzbox-4040
 	BOARD_NAME := fritz4040
 	DEVICE_TITLE := AVM Fritz!Box 4040
 	IMAGE_SIZE := 29753344
-	IMAGES = sysupgrade.bin
+	UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+	UBOOT_PARTITION_SIZE := 524288
+	IMAGES = eva.bin sysupgrade.bin
+	IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
 	IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
 	DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
 endef