From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 20 Jul 2015 10:50:46 +0000 (+0000)
Subject: tools: drop circular dependency between patch and ccache, build patch without ccache... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=9402cb747ef51c43046b7159061afb50a4302f3b;p=openwrt%2Fstaging%2Fansuel.git

tools: drop circular dependency between patch and ccache, build patch without ccache (fixes #20132)

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 46434
---

diff --git a/tools/Makefile b/tools/Makefile
index 8b5dd6c520..60041ddc31 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -73,7 +73,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/install
 $(curdir)/patchelf/compile := $(curdir)/libtool/install
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
 tools-y += ccache
 endif
 
diff --git a/tools/patch/Makefile b/tools/patch/Makefile
index 94b3607592..4774478c96 100644
--- a/tools/patch/Makefile
+++ b/tools/patch/Makefile
@@ -15,4 +15,7 @@ PKG_MD5SUM:=e3da7940431633fb65a01b91d3b7a27a
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
 $(eval $(call HostBuild))