From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 31 Oct 2015 09:29:38 +0000 (+0000)
Subject: ar71xx/image: remove old unused build code for TPLINKOLD
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=958c7858684f32053e4f737f850eafeeb4ed3537;p=openwrt%2Fstaging%2Fnbd.git

ar71xx/image: remove old unused build code for TPLINKOLD

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>

SVN-Revision: 47320
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b35190dac4..141a2d7133 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1891,38 +1891,6 @@ define Image/Build/Senao
 		$(call sysupname,$(1),$(2))
 endef
 
-Image/Build/TPLINKOLD/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
-
-define Image/Build/TPLINKOLD
-	[ -e "$(KDIR)/loader-$(2).gz" ]
-	$(call MkuImageOKLI,$(2))
-	( \
-		dd if=$(KDIR)/loader-$(2).gz bs=7680 count=1 conv=sync; \
-		dd if=$(KDIR_TMP)/vmlinux-$(2).okli conv=sync; \
-	) > $(KDIR_TMP)/kernel-$(2).bin
-	-$(STAGING_DIR_HOST)/bin/mktplinkfw \
-		-H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION)\
-		-X 0x40000 \
-		-k $(KDIR_TMP)/kernel-$(2).bin \
-		-r $(KDIR)/root.$(1) \
-		-o $(call factoryname,$(1),$(2))
-	-$(STAGING_DIR_HOST)/bin/mktplinkfw \
-		-H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s\
-		-X 0x40000 \
-		-k $(KDIR_TMP)/kernel-$(2).bin \
-		-r $(KDIR)/root.$(1) \
-		-o $(call sysupname,$(1),$(2))
-endef
-
-define Image/Build/TPLINKOLD/initramfs
-	$(call Image/BuildLoader,$(2),gz,$(3),0x80060000,-initramfs)
-	-$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
-		-H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s\
-		-k $(KDIR)/loader-$(2)-initramfs.gz \
-		-o $(call imgname,$(1),$(2))-initramfs-uImage.bin
-endef
-
-
 Image/Build/TPLINK/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
 
 define Image/Build/TPLINK